package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Pyt|hon`)
var str = `Python language
python algorithm
code Pytthon
Python script
more repetitions Pyththththtthon
zero occurrences Py Pyttt-pyPyth`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}