import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Pyt|hon";
final String string = "Python language\n"
+ "python algorithm\n"
+ "code Pytthon\n"
+ "Python script\n"
+ "more repetitions Pyththththtthon\n"
+ "zero occurrences Py Pyttt-pyPyth";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}