import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(\\\"[^\\\"\\r\\n\\t]+\\\"|[a-z0-9\\_]+)\\s?\\:\\s([a-z\\[\\]0-9]+)\\s?(\\'[^\\'\\;]+\\'|\\\"[^\\\"\\;]+\\\"|of [^\\\"\\;]+|[^\\\"\\s\\;]+|)( temporary)?\\;";
final String string = " \"lel lel\": Boolean;\n"
+ " \"lel lel\": Record \"Sales Header\";\n"
+ " lellel: Record \"Sales Header\";\n"
+ "Customer: Record Customer;\n"
+ " Lookup: Xmlport \"DataCustomer\";\n"
+ "Test1: Label \"Hallo\";\n"
+ "Test1: Label 'Hallo';\n"
+ " \"lel lel\": Integer;\n"
+ " AbsenceAmountType: Option \"Net Change\",\"Balance at Date\";\n"
+ " MATRIX_CellData: array[32] of Decimal;\n"
+ " MATRIX_ColumnCaption: array[32] of Text[1024];\n"
+ " CauseOfAbsenceFilter: Code[10];\n"
+ " NoSeriesCode: Code[20];\n"
+ " trigger Timer::Elapsed(sender: Variant; e: DotNet EventArgs)\n"
+ " ToolTip = 'Specifies how amounts are displayed. Net Change: The net change in the balance for the selected period. Balance at Date: The balance as of the last day in the selected period.';\n"
+ " \"Base X-Axis on\" := \"Base X-Axis on\"::Period;\n"
+ " MATRIX_GenerateColumnCaptions(SetWanted::Initial);\n"
+ " TempItemAttributeValue: Record \"Item Attribute Value\" temporary;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}