use strict;
my $str = ' "lel lel": Boolean;
"lel lel": Record "Sales Header";
lellel: Record "Sales Header";
Customer: Record Customer;
Lookup: Xmlport "DataCustomer";
Test1: Label "Hallo";
Test1: Label \'Hallo\';
"lel lel": Integer;
AbsenceAmountType: Option "Net Change","Balance at Date";
MATRIX_CellData: array[32] of Decimal;
MATRIX_ColumnCaption: array[32] of Text[1024];
CauseOfAbsenceFilter: Code[10];
NoSeriesCode: Code[20];
trigger Timer::Elapsed(sender: Variant; e: DotNet EventArgs)
ToolTip = \'Specifies how amounts are displayed. Net Change: The net change in the balance for the selected period. Balance at Date: The balance as of the last day in the selected period.\';
"Base X-Axis on" := "Base X-Axis on"::Period;
MATRIX_GenerateColumnCaptions(SetWanted::Initial);
TempItemAttributeValue: Record "Item Attribute Value" temporary;';
my $regex = qr/\s(\"[^\"\r\n\t]+\"|[a-z0-9\_]+)\s?\:\s([a-z\[\]0-9]+)\s?(\'[^\'\;]+\'|\"[^\"\;]+\"|of [^\"\;]+|[^\"\s\;]+|)( temporary)?\;/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}