import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!#[^\\n]*)\\((?![^()]*\\)\\))";
final String string = "TropicalFruitTOutput::TropicalFruitTOutput()\n"
+ " : dad::CRunnable()\n"
+ " , m_watermelon_out()\n"
+ "#if MAX_FRUITS == (10)\n"
+ " , m_cherry_out()\n"
+ "#endif\n"
+ "{\n"
+ "}\n\n"
+ "NationalFruitInput::NationalFruitInput()\n"
+ " , m_banana_in()\n"
+ " , m_dragronFruit(PAD_GetdragronFruitPAD_B(xcxcxc))\n"
+ "{\n"
+ "}\n\n"
+ "SpecialFruits::SpecialFruits()\n"
+ " : AmazingClassType()\n"
+ " , m_kiwi()\n"
+ " , m_avocado( // PRQA S 2961 # FALSEPOSITIVE QAC warning about uninitialized\n"
+ " // Hello world\n"
+ " // This is just a comment for\n"
+ " // testing purpose\n"
+ " m_apricotController.getApricotList())\n"
+ "{\n"
+ "}\n\n"
+ "using NewFruitsBase::NewFruitsBase;\n";
final String subst = "{";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}