const regex = new RegExp('(?<!#[^\\n]*)\\((?![^()]*\\)\\))', 'gms')
const str = `TropicalFruitTOutput::TropicalFruitTOutput()
: dad::CRunnable()
, m_watermelon_out()
#if MAX_FRUITS == (10)
, m_cherry_out()
#endif
{
}
NationalFruitInput::NationalFruitInput()
, m_banana_in()
, m_dragronFruit(PAD_GetdragronFruitPAD_B(xcxcxc))
{
}
SpecialFruits::SpecialFruits()
: AmazingClassType()
, m_kiwi()
, m_avocado( // PRQA S 2961 # FALSEPOSITIVE QAC warning about uninitialized
// Hello world
// This is just a comment for
// testing purpose
m_apricotController.getApricotList())
{
}
using NewFruitsBase::NewFruitsBase;
`;
const subst = `{`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);