package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)([\r\n]+)`)
var str = `\`ifndef abc\`define abc
module xyz(
block
#(
.BLK (def::a)
)
inst
(/*AUTOINST*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}