$re = '/(\w+)([\r\n]+)/m';
$str = '`ifndef abc`define abc
module xyz(
block
#(
.BLK (def::a)
)
inst
(/*AUTOINST*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);