const regex = /(?<=DOB:)(.|\n)*(?=Last Name)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=DOB:)(.|\\n)*(?=Last Name)', 'gm')
const str = `
DOB:
11/27/1960
Last Name:
Doe
First Name:
John`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}