$re = '/(?<=DOB:)(.|\n)*(?=Last Name)/m';
$str = '
DOB:
11/27/1960
Last Name:
Doe
First Name:
John';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);