import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([12]\\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\\d|3[01]))";
final String string = "1900-10-23\n"
+ "2002-5-5\n"
+ "2009-23-5\n"
+ "2008-09-31\n"
+ "1600-12-25\n"
+ "1942-11-1\n"
+ "1942-11-0\n"
+ "1942-00-25\n"
+ "2000-10-00\n"
+ "2000-10-10\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}