$re = '/([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))/m';
$str = '1900-10-23
2002-5-5
2009-23-5
2008-09-31
1600-12-25
1942-11-1
1942-11-0
1942-00-25
2000-10-00
2000-10-10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);