$re = '/(?!\B"[^"|“|”]*)\b(and|or|not|exclude)(?=.*[\s])\b(?![^"|“|”]*"\B)/iu';
$str = '\'(Java or "化粧" or 化粧品)\'
\'(Java or 化粧 or 化粧品)\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);