re = /(?!\B"[^"|“|”]*)\b(and|or|not|exclude)(?=.*[\s])\b(?![^"|“|”]*"\B)/i
str = '\'(Java or "化粧" or 化粧品)\'
\'(Java or 化粧 or 化粧品)\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end