package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *(.*[^\d\s])(?: *(\d+))? *$`)
var str = `Battery Bank 1
Dummy 32 Segment 1
System
Modbus 192.168.0.1 Group`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}