$re = '/^ *(.*[^\d\s])(?: *(\d+))? *$/m';
$str = 'Battery Bank 1
Dummy 32 Segment 1
System
Modbus 192.168.0.1 Group';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);