import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://download\\.mozilla\\.org/\\?product=thunderbird-[0-9.]*-SSL\\&os=win64\\&lang=de";
final String string = "https://download.mozilla.org/?product=thunderbird-91.6.0-SSL&os=win64&lang=de\n"
+ "https://download.mozilla.org/?product=thunderbird-91.6.0-msi-SSL&os=win64&lang=de";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}