re = /https:\/\/download\.mozilla\.org\/\?product=thunderbird-[0-9.]*-SSL\&os=win64\&lang=de/m
str = 'https://download.mozilla.org/?product=thunderbird-91.6.0-SSL&os=win64&lang=de
https://download.mozilla.org/?product=thunderbird-91.6.0-msi-SSL&os=win64&lang=de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end