package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^.]*\bJavaScript\b[^.]*\.`)
var str = `JavaScript flavors of RegEx are supported.
Edit the Expression & Text to see the matches.
Roll over matches or the expression for details.
PCRE & JavaScript flavors of RegEx are supported.
Validate your expression with Tests mode.
Edit the Expression & Text to see the matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}