// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^.]*\bJavaScript\b[^.]*\.").unwrap();
let string = "JavaScript flavors of RegEx are supported.
Edit the Expression & Text to see the matches.
Roll over matches or the expression for details.
PCRE & JavaScript flavors of RegEx are supported.
Validate your expression with Tests mode.
Edit the Expression & Text to see the matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}