$re = '/(?<=AccessControlRuleName:)[\w ]*(?=,)/m';
$str = 'FPWR2120_Access, AccessControlRuleName: Guest IPS and Malware Inspect, Prefilter Policy:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);