re = /(?<=AccessControlRuleName:)[\w ]*(?=,)/m
str = 'FPWR2120_Access, AccessControlRuleName: Guest IPS and Malware Inspect, Prefilter Policy:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end