package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(.+)(((and|or)\s+)?)+`)
var str = `test1 test2 and test2 or test4 test5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}