$re = '/\+(98|0)?9\d{9}/';
$str = 'sdas+98917292912365';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);