using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s+Plan(?!.*Plan)";
string input = @"Birla Sun Life Global Real Estate Fund - Retail Plan - Direct Plan - Growth Option'; ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}