re = /(\w+)\s+Plan(?!.*Plan)/
str = 'Birla Sun Life Global Real Estate Fund - Retail Plan - Direct Plan - Growth Option\'; '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end