#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^][]+)"
Local $sString = "Palais et bâtiments officiels[modifier | modifier le code]" & @CRLF & _
"Lieux de culte renommés[modifier | modifier le code]" & @CRLF & _
"Vestiges gallo-romains[modifier | modifier le code]""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")