using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^][]+)";
string input = @"Palais et bâtiments officiels[modifier | modifier le code]
Lieux de culte renommés[modifier | modifier le code]
Vestiges gallo-romains[modifier | modifier le code]""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}