$re = '/^[0-9]{1,11}(?:(?<=\d{11})-(?:[0-9]{6})?)?$/m';
$str = '1234
1234567
123456789
12345678900-
12345678900-123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);