re = /^[0-9]{1,11}(?:(?<=\d{11})-(?:[0-9]{6})?)?$/m
str = '1234
1234567
123456789
12345678900-
12345678900-123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end