#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(.*?)?&?tag=[^&]*?(&.*)?$"
Local $sString = "# Match" & @CRLF & _
"test=dsfsdfsdfdsfsdltag&tag=sdfdsfsdfdsfds&blah=sdfdsfdsfds&fsdfsdfsdf" & @CRLF & _
"fillHeight=191&fillWidth=340&quality=96&tag=736d0dfc2ad7fc74d1f8a6a655b540ae" & @CRLF & _
"test=dsfsdfsdfdsfsdltag&tag=sdfdsfsdfdsfds" & @CRLF & _
"" & @CRLF & _
"# No match" & @CRLF & _
"test=dsfsdfsdfdsfsdltag&blah=sdfdsfdsfdstag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")