$re = '/^(.*?)?&?tag=[^&]*?(&.*)?$/mi';
$str = '# Match
test=dsfsdfsdfdsfsdltag&tag=sdfdsfsdfdsfds&blah=sdfdsfdsfds&fsdfsdfsdf
fillHeight=191&fillWidth=340&quality=96&tag=736d0dfc2ad7fc74d1f8a6a655b540ae
test=dsfsdfsdfdsfsdltag&tag=sdfdsfsdfdsfds
# No match
test=dsfsdfsdfdsfsdltag&blah=sdfdsfdsfdstag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);