const regex = /^.*?([0-9]+),([0-9]+)\s*€\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?([0-9]+),([0-9]+)\\s*€\\s*$', 'gm')
const str = `765,38 € 650,00 € `;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);