package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/(?:[A-z0-9_-]+\/)+([0-9]+(?:\.[0-9])*)`)
var str = `/etc/vol/12.0.1/path`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}