$re = '/^\/(?:[A-z0-9_-]+\/)+([0-9]+(?:\.[0-9])*)/m';
$str = '/etc/vol/12.0.1/path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);