const regex = /((?:[A-Z][a-z]\.|\w\.\w.|.)*?[.!?])(?:\s+|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[A-Z][a-z]\\.|\\w\\.\\w.|.)*?[.!?])(?:\\s+|$)', 'g')
const str = `Mr. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}