$re = '/^"|"$|"(?=,")|(?<=",)"/m';
$str = '"Here is an "example" text","Here is another "example" text"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);