re = /^"|"$|"(?=,")|(?<=",)"/m
str = '"Here is an "example" text","Here is another "example" text"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end