using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"52A:(?:(?![0-9]{2}[A-Z]?:).)*[A-Z]{6}[A-Z0-9]{2}(?:[0-9]{3}|XXX)?";
string input = @"52A:AAAAAAAAXXX
52A:somerubbish:57D:AAAAAAAAXXX
52A:test:testAAAAAAAAXXX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}