$re = '/52A:(?:(?![0-9]{2}[A-Z]?:).)*[A-Z]{6}[A-Z0-9]{2}(?:[0-9]{3}|XXX)?/m';
$str = '52A:AAAAAAAAXXX
52A:somerubbish:57D:AAAAAAAAXXX
52A:test:testAAAAAAAAXXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);