$re = '/\r/';
$str = 'Reason
REASON, n. re\'zn. [L. ratio, which is from ratus, and which proves reor ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);