re = /\r/
str = 'Reason
REASON, n. re\'zn. [L. ratio, which is from ratus, and which proves reor '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end