import re
regex = re.compile(r"([A-Z ]+)\n--(.*?)--\n(.*?)\n\n", flags=re.MULTILINE | re.DOTALL)
test_str = ("Washington, DC November 27, 2019\n"
"USDA Truck Rate Report\n\n"
"WA_FV190\n\n"
"FIRST PRICE RANGE FOR WEEK OF NOVEMBER 20-26 2019\n"
"SECOND PRICE MOSTLY FOR TUESDAY NOVEMBER 26 2019\n\n"
"PERCENTAGE OF CHANGE FROM TUESDAY NOVEMBER 19 2019 SHOWN IN ().\n\n"
"In areas where rates are based on package rates, per-load rates were\n"
"derived by multiplying the package rate by the number of packages in\n"
"the most usual load in a 48-53 foot trailer.\n\n"
"CENTRAL AND WESTERN ARIZONA\n"
"-- LETTUCE, BROCCOLI, CAULIFLOWER, ROMAINE AND LEAF LETTUCE SLIGHT SHORTAGE\n"
"--\n\n"
"ATLANTA 5100 5500\n"
"BALTIMORE 6300 6600\n"
"BOSTON 7000 7300\n"
"CHICAGO 4500 4900\n"
"DALLAS 3400 3800\n"
"MIAMI 6400 6700\n"
"NEW YORK 6600 6900\n"
"PHILADELPHIA 6400 6700\n\n"
" 2019 2018\n\n"
" NOV 17-23 NOV 18-24\n\n"
"U.S. 25,701 22,956\n"
"IMPORTS 13,653 15,699\n"
" ------------ --------------\n"
"sum 39,354 38,655")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")