use strict;
my $str = '1 0839854268058 0002611724 101312366 0712170000000020887041 08A24111718 1000000000100 0100001065768010JULIO CEZAR OZORIO DA SILVA BL S AP 202 0200194800000ALVORADA RS 000002';
my $regex = qr/\d{1}\s{16}(\d{4})(\d{9})\s{7}[A-Z\s]{25}(\d{10})[A-Za-z\s]{32}\s{3}\d{1}\d{2}[A-Za-z\s\d]{10}(\d{6})(\d{13})\d{3}\s{5}\d{2}[A-Z]{1}(\d{6})\d{2}\s{2}\d{13}\s{45}\d{2}(\d{14})([A-Z\s]{35})\s{5}([A-Z0-9\s]{40})\s{7}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}