#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*?([ ']).*\1)[a-zA-Z ']+$"
Local $sString = "a" & @CRLF & _
" " & @CRLF & _
" '" & @CRLF & _
"''" & @CRLF & _
"'" & @CRLF & _
"a " & @CRLF & _
" 'a" & @CRLF & _
"foo bar'baz" & @CRLF & _
"foo'barbarbara baz" & @CRLF & _
"foo barbarbara baz" & @CRLF & _
" foo'" & @CRLF & _
"ab c''" & @CRLF & _
"!""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")