$re = '/^(?!.*?([ \']).*\1)[a-zA-Z \']+$/m';
$str = 'a
\'
\'\'
\'
a
\'a
foo bar\'baz
foo\'barbarbara baz
foo barbarbara baz
foo\'
ab c\'\'
!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);