import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[^|])[^][|]*(?:(\\[[^][]*+(?:(?1)[^][]*)*+])[^][|]*)*";
final String string = "action=search sourcetype=audittrail [ localop | stats count | eval search_id = replace(\"$top10_drilldown_sid$\", \"^remote_[^_]*_\", \"\") | table search_id ] [ localop | stats count | eval earliest = $top10_drilldown_earliest$ - 86400 | table earliest ] latest=\"$top10_drilldown_latest$\" | stats values(savedsearch_name) AS search_name";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}