const regex = /(?=[^|])[^][|]*(?:(\[[^][]*+(?:(?1)[^][]*)*+])[^][|]*)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[^|])[^][|]*(?:(\\[[^][]*+(?:(?1)[^][]*)*+])[^][|]*)*', 'g')
const str = `action=search sourcetype=audittrail [ localop | stats count | eval search_id = replace("\$top10_drilldown_sid\$", "^remote_[^_]*_", "") | table search_id ] [ localop | stats count | eval earliest = \$top10_drilldown_earliest\$ - 86400 | table earliest ] latest="\$top10_drilldown_latest\$" | stats values(savedsearch_name) AS search_name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}