package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)correlation-sit=(?<app>[A-Za-z]+)(?<version>\d+\.\d+\.\d+)`)
var str = `<< uri="get api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106", SERVICE_PREFIX="get api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106", path="get api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106", resourceMethod="get", HTTP_METHOD="get", resourceUri="api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}