// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)correlation-sit=(?<app>[A-Za-z]+)(?<version>\d+\.\d+\.\d+)").unwrap();
let string = "<< uri=\"get api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106\", SERVICE_PREFIX=\"get api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106\", path=\"get api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106\", resourceMethod=\"get\", HTTP_METHOD=\"get\", resourceUri=\"api/mydetails/1.0.0/apime/employee-details?correlation-sit=sgs1.0.18u%26h%3d106\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}